Project

General

Profile

Actions

Testing #893

closed

System Integration Tests for Harkonnen Release

Added by Hammel over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Immediate
Assignee:
Category:
09 - Testing
Target version:
Start date:
28 Feb 2022
Due date:
% Done:

100%

Estimated time:
Severity:
03 - Medium

Description

Feature development is essentially complete for the PiBox 2.0 - Harkonnen release. However, full integration tests need to be run to validate existing functionality passes regression and new features are at least stable, if not bug free.

The following systems need to be fully tested. A test plan has been written for each one. Separate issues will be written for each testplan and test status will be tracked here. Platforms represent the devices on which the system was tested.

Test Suite Platforms
System Test Plan RPi 1 RPi 2 RPi 3 Zero Zero W Desktop
Dev Platform DevPlatform Pass Pass Pass Pass Pass n/a
Media System MediaSystem n/a Pass Pass n/a n/a n/a
Media Player (4) Media_Player Pass Pass Pass n/a n/a n/a
Kiosk Kiosk Pass Pass Pass Pass(2) Pass(2) n/a
Auto Kiosk Auto_Kiosk Pass Pass Pass Pass Pass n/a
PiStore (5) PiStore n/a N/A Pass n/a n/a n/a
PiSentry (5) PiStore n/a N/A Pass n/a n/a n/a
Desktop (VideoLib) VideoLib n/a n/a n/a n/a n/a Pass

Platform Notes

  1. This is the first full test suite run on system builds, as system builds are new to this release. This means there really isn't any regression testing and all tests are new feature testing.
  2. These tests were started in September 2022. Supply chain issues make acquisition of new boards nearly impossible unless you get on a wait list. Replacing dead boards won't happen for awhile, I think.
  3. Media Player works better if Media Server is wired to an access point instead of being the access point.
  4. PiStore and PiSentry are only supported on Raspberry Pi 3, mainly because Raspberry Pi 2 appears discontinued on most Raspberry Pi official retailer sites.

Notes on Passed Tests

  1. Caveats listed in comment #note-8.
  2. Tested with an HDMI monitor.

Test Summaries

  • Based on test results for PiBox 2.0, PiBox 3.0 will focus on, but is not limited to, the following items.
    • Integrate use of GPU for drawing to speed up display on Zero's and Pi 1's.
    • More flexible display handling for touchscreens.
    • Possibly adding sensor systems on Zero/Zero W boards to integrate with the Ironman project.

Related issues

Related to PiBox - Testing #894: Generate release candidates builds: HarkonnenClosedHammel14 Apr 2022

Actions
Blocked by launcher - Bug #949: Pi Zero doesn't work with keyboards using elecrow 5" HDMI displayClosedHammel24 Mar 2023

Actions
Copied to PiBox - Testing #1044: System Integration Tests for Corrino (v3.0) ReleaseNewHammel28 Feb 2022

Actions
Actions #1

Updated by Hammel about 2 years ago

  • Description updated (diff)
  • Status changed from New to In Progress
  • % Done changed from 0 to 10
Actions #2

Updated by Hammel almost 2 years ago

  • Description updated (diff)
Actions #3

Updated by Hammel almost 2 years ago

  • Description updated (diff)
Actions #4

Updated by Hammel almost 2 years ago

Ready to test
  1. Dev platform, rpi1 pizero/w
  2. Dev platform, rpi2 model B
Then make and test
  1. Dev platform, rpi1 model B+
  2. Dev platform, rpi3 Model B+
Actions #5

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #6

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #7

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #8

Updated by Hammel over 1 year ago

  • Description updated (diff)

Pi Zero, Dev Platform

Subsystem Feature Test Status Notes
Display: Desktop Boot to UI Pass
Display: 7" Touchscreen Boot to UI N/A Only tested against HDMI, not touchscreen
UI X org Boot to UI Pass
Shell Command History Pass HWorks: wired keyboard keypad w/ numlock off; Fails: FAVI kb
Utilities HW ID Examine pibox-config, pibox-version Pass
Input Keyboard FAVI kb Pass Arrow keys do not work in history.
Mouse FAVI kb touchpad Pass
Touchscreen RPi official touchscreen N/A
Net Config UI Verify UI
Interface Static IP
DHCP
Access Point
Scanner Visual display of local WiFi signals

Notes

  • Boot time for the Pi Zero is about 40 seconds from power on to the UI.

Retest Status

  • All tests passed.

Pi Zero W, Dev Platform

Subsystem Feature Test Status Notes
Display: Desktop Boot to UI Pass
Display: 7" Touchscreen Boot to UI N/A Only tested against HDMI, not touchscreen
UI X org Boot to UI Pass
Shell Command History Pass Works: wired keyboard keypad w/ numlock off; Fails: FAVI kb
Utilities HW ID Examine pibox-config, pibox-version Pass
Input Keyboard FAVI kb Pass Arrow keys do not work in history.
Mouse FAVI kb touchpad Pass
Touchscreen RPi official touchscreen N/A
Net Config PNC UI Verify UI Pass(2) brcmfmac flashing issue fixed.
PNC Config Static IP Not tested.
DHCP Not tested.
Access Point Pass Wifi AP started correctly and can be connected to but dhcpd did not start properly.
HW Wired Pass
WiFi Pass (2) WiFi wpasupplicant configured okay, but switch from AP to client left AP static config in interfaces.
Scanner Visual display of local WiFi signals Pass Tested using on-board wifi

Notes (Original test)

  1. Boot time for the Pi Zero W is about 35 seconds to the UI.
  2. The X.org display (and console display too, during boot before X starts) blinks on and off. Disabling wifi (see RM #845) fixes the problem. Retested with better power supply (5.25V @ 2.5A, rated to fix undervoltage in RPi's using microUSB power port) did not solve the problem with wifi enabled. This makes the Zero W useless for PiPlayer but it could still work for kiosk and autokiosk.

Retest status

  • All tests passed. This includes the display flashing with brcmfmac, which is no longer present even with a wired keyboard, wireless keyboard and usb wired network dongle added to an unpowered usb hub attached to the Zero's usb port. It is unclear if this was fixed with a different power source or with code, though I suspect the former.
Actions #9

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #10

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #11

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #12

Updated by Hammel over 1 year ago

RPi 2 Model B, Dev Platform

Subsystem Feature Test Status Notes
Display: Desktop Boot to UI Pass
Display: 7" Touchscreen Boot to UI N/A Only tested against HDMI, not touchscreen
UI X org Boot to UI Pass
Shell Command History Pass History works using a wired keyboard's keypad with numlock turned off.
Utilities HW ID Examine pibox-config, pibox-version Pass
Input Keyboard FAVI kb Pass Arrow keys do not work in history.
Mouse FAVI kb touchpad Pass
Touchscreen RPi official touchscreen N/A
Net Config PNC UI Verify UI Pass
PNC Config Static IP Pass (1) Tested on eth0
DHCP Pass Tested on eth0
Access Point Pass
HW Wired Pass
WiFi Pass (2) WiFi connects but no dhcp
Scanner Graph of WiFi signals Pass

Notes on Passed Tests

  1. Multiple empty nameserver entries written to /etc/resolv.conf. See RM #901
  2. dhcpd daemon is not started so no DHCP address is given to clients.

Notes on Failed Tests

Retest Status

  1. All tests pass
Actions #13

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #14

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #15

Updated by Hammel over 1 year ago

RPi 1 Model B+, Dev Platform

Subsystem Feature Test Status Notes
Display: Desktop Boot to UI Pass
Display: 7" Touchscreen Boot to UI N/A Only tested against HDMI, not touchscreen
UI X org Boot to UI Pass
Shell Command History Pass History works using a wired keyboard's keypad with numlock turned off.
Utilities HW ID Examine pibox-config, pibox-version Pass
Input Keyboard FAVI kb Pass Arrow keys do not work in history.
Mouse FAVI kb touchpad Pass
Touchscreen RPi official touchscreen N/A
Net Config PNC UI Verify UI Pass
PNC Config Static IP Pass (1) Tested on eth0
DHCP Pass Tested on eth0
Access Point Pass
HW Wired Pass
WiFi Pass (2) WiFi connects but no dhcp
Scanner Graph of WiFi signals Pass

Notes on Passed Tests

  1. Multiple empty nameserver entries written to /etc/resolv.conf. See RM #901
  2. dhcpd daemon is not started so no DHCP address is given to clients.

Notes on Failed Tests

Retest Status

  1. All tests pass.
Actions #16

Updated by Hammel over 1 year ago

RPi 3 Model B+, Dev Platform

Subsystem Feature Test Status Notes
Display: Desktop Boot to UI Pass
Display: 7" Touchscreen Boot to UI Pass
UI X org Boot to UI Pass
Shell Command History Pass History works using a wired keyboard's keypad with numlock turned off.
Utilities HW ID Examine pibox-config, pibox-version Pass
Input Keyboard FAVI kb Pass Arrow keys do not work in history.
Mouse FAVI kb touchpad Pass
Touchscreen RPi official touchscreen Pass Works poorly on dev platform because touchscreen is not calibrated.
Net Config PNC UI Verify UI Pass (1) HDMI only.
PNC Config Static IP Pass
DHCP Pass
Access Point Pass (2)
HW Wired Pass
WiFi Pass (2)
Scanner Graph of WiFi signals Pass

Notes on Passed Tests

  1. PNC is too large vertically to be used on a horizontally oriented 7" touchscreen.
  2. Dongle only - brcm doesn't work well enough yet.

Notes on Failed Tests

Retest Status

  1. All tests passed
Actions #17

Updated by Hammel over 1 year ago

  • Description updated (diff)
  • % Done changed from 10 to 20
Next to test
  1. Media System, rpi2 model B (just add system packages to SD)
  2. Media System, rpi3 model B+ (just add system packages to SD)
  3. Media System, rpi3 model B+, touchscreen (just add system packages to SD)
Then make and test
  1. Media Player System, rpi1 model B+
  2. Media Player System, rpi2 model B+
  3. Media Player System, rpi3 Model B+
  4. Media Player System, rpi3 Model B+, touchscreen
Actions #18

Updated by Hammel over 1 year ago

RPi 2 Model B, Media System

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
Network Wired Eth gets DHCP Pass
UI Matchbox App overlays launcher Pass
Laucher Icons x rows by y columns icons Pass
Splash Displays large icon per app Pass
Date/time Pass
Navigation Use kb arrows to nav app selection Pass
App Manager Start app via launcher Pass
VideoFE Selection Arrow keys Pass
Search Pass
Playback Start video Pass
FF Pass
Rewind Pass
Rescan DB Plugin USB Media stick with videos Fail (1) See RM #783
Exit Pass
Full screen Pass
Video Formats Test multiples files Pass
MusicFE Selection by title Arrow Keys Pass Forward and Back arrow keys only.
Selection by Artist Arrow Keys Pass Forward and Back arrow keys only.
Playback Start audio Pass
FF Fail (2) See RM #921
Rewind Fail (2) See RM #921
Exit Pass
PiClock Clock Check time, multiple seconds Pass
Calendar Check/modify date Fail (3) See RM #923
PiCam Video Display Start video Pass See RM #924
Exit video Pass
PiXM Navigation By channel id Pass (7) See RM #937
By category Pass
Scanning Categories Pass
Channels Pass
UI Online icon Pass
Mute icon Pass
Output Playback start Pass
Playback stop Pass (8)
PiPics Nav, kb FF Pass
Rewind Pass
Nav, touchscreen FF N/A Touchscreen only supported with kiosk systems
Rewind N/A Touchscreen only supported with kiosk systems
Net Config UI Verify UI Pass (2) See RM #925
Interface Static IP Pass
DHCP Pass (3)
Access Point Pi accepts WiFi connections Pass (5)
Scanner Visual display of local WiFi signals Pass (4) See RM #926
WebUI Users Login Pass
Add Pass
Delete Pass
Password Change Pass
WebCam Normal Orientation Pass (1) See RM #936
Flip Orientation Pass
Net Config Interface Pass
Access Point Pass (6)

Notes on Passed Tests

  1. piboxd is not handling webcam resolution changes well, requiring restarts of piboxd (via reboots for the user).
  2. IPaddress field not updated when changing selected interface.
  3. Eth: works. WiFi: Configuration works as expected but interface does not connect to router.
  4. Scanner doesn't work if dongle inserted after boot.
  5. Net Config (re: PNC, and probably the WebUI) do not update the default dhcpd.conf file with specified base address, but if this is done manually then the access point works. Also, hostapd.conf needs to use CCMP and not TKIP for latest model phones (most likely). TKIP should be a fallback configuration.
  6. The current base address field is not populated in the WebUI's Access Point tab.
  7. The app crashes moments after starting to play a station.
  8. There is no playback stop except to exit the app gracefully.

Notes on Failed Tests

  1. Display not updated on plug-in or pull-out events.
  2. MusicFE plays music from a tree of files with MP3 tags, which is good enough for this release. It has several bugs that will be addressed in future releases.
  3. Changing the time only affects the UI, not the system time. The date (in the calendar) can't be changed using the FAVI keyboard.

Retest Status

  1. All failed tests with fixed issues passed on retest.
Actions #19

Updated by Hammel over 1 year ago

RPi 3 Model B+, Media System

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
Network Wired Eth gets DHCP Pass
UI Matchbox App overlays launcher Pass
Laucher Icons x rows by y columns icons Pass
Splash Displays large icon per app Pass
Date/time Pass
Navigation Use kb arrows to nav app selection Pass
App Manager Start app via launcher Pass
VideoFE Selection Arrow keys Pass
Search Pass
Playback Start video Pass
FF Pass
Rewind Pass
Rescan DB Plugin USB Media stick with videos Fail (1) See RM #783
Exit Pass
Full screen Pass
Video Formats Test multiples files Pass
MusicFE Selection by title Arrow Keys Pass
Selection by Artist Arrow Keys Pass
Playback Start audio Pass
FF Fail (2) See RM #921
Rewind Fail (2) See RM #921
Exit Pass
PiClock Clock Check time, multiple seconds Pass
Calendar Check/modify date Fail (3) See RM #923
PiCam Video Display Start video Pass (4) See RM #924
Exit video Pass
PiXM Navigation By channel id Pass (5) See RM #937
By category Pass
Scanning Categories Pass
Channels Pass
UI Online icon Pass
Mute icon Pass
Output Playback start Pass
Playback stop Pass (6)
PiPics Nav, kb FF Pass
Rewind Pass
Nav, touchscreen FF N/A Touchscreen only supported with kiosk systems
Rewind N/A Touchscreen only supported with kiosk systems
Net Config UI Verify UI Pass
Interface Static IP Pass
DHCP Pass (1) See RM #933
Access Point Pi accepts WiFi connections Pass (2)
Scanner Visual display of local WiFi signals Pass
WebUI Users Login Pass
Add Pass
Delete Pass
Password Change Pass
WebCam Normal Orientation Pass (3) See RM #936
Flip Orientation Pass
Net Config Interface Pass
Access Point Pass (4) See RM #904

Notes on Passed Tests

  1. udhcpc does not properly restart, leaving old instances running when a new one is started on network updates. Eth: works. WiFi: Configuration works as expected but interface does not connect to router.
  2. Net Config (re: PNC, and probably the WebUI) do not update the default dhcpd.conf file with specified base address, but if this is done manually then the access point works. Also, hostapd.conf needs to use CCMP and not TKIP for latest model phones (most likely). TKIP should be a fallback configuration.
  3. piboxd is not handling webcam resolution changes well, requiring restarts of piboxd (via reboots for the user).
  4. The current base address field is not populated in the WebUI's Access Point tab.
  5. The app crashes moments after starting to play a station.
  6. There is no playback stop except to exit the app gracefully.

Notes on Failed Tests

  1. Display not updated on plug-in or pull-out events.
  2. MusicFE plays music from a tree of files with MP3 tags, which is good enough for this release. It has several bugs that will be addressed in future releases.
  3. Changing the time only affects the UI, not the system time. The date (in the calendar) can't be changed using the FAVI keyboard.
  4. No video output. mjpeg, omxplayer appear to be running correctly.

Retest Status

  1. All failed tests with fixed issues passed on retest.
Actions #20

Updated by Hammel over 1 year ago

  • Related to Testing #765: Test PiZero with media, kiosk and auto-kiosk builds added
Actions #21

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #22

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #23

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #24

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #25

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #26

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #27

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #28

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #29

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #30

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #31

Updated by Hammel over 1 year ago

  • Description updated (diff)

RPi 2 Model B+, Media Player

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
Network Wired Eth gets DHCP Pass
UI Matchbox App overlays launcher Pass
Launcher Icons x rows by y columns icons Pass
Date/time Pass
Navigation Use kb arrows to nav app selection Pass
App Manager Start app via launcher Pass
PiNet Touch Interface Exit N/A
Web Config Access Point config Pass
Wireless client UI Pass
Wireless client config Pass Works after fixing wpa_supplicant.conf to match router. See RM #904
Piboxd SMB mounts Pass
VideoFE Selection Arrow keys Pass
Search Pass
Title access, SMB Pass
Title access, USB/SMB combined Pass
Playback Start video, USB Pass
Start video, SMB Pass
FF Pass
Rewind Pass
Exit Pass
Full screen Pass
Video Formats Test multiples files Pass (2) MP4 doesn't stream well
Video Stream Stream from Media System Pass
MusicFE Selection by title Arrow Keys Pass (1) Long startup time and slow movement
Selection by Artist Arrow Keys Pass
Playback Start audio Pass
FF Fail See RM #921
Rewind Fail See RM #921
Exit Pass

Notes on Passed Tests

  1. MusicFE works but poorly. More work is needed on this app.
  2. AVI, MKV and MOV streamed fine from Media System. MP4 stops playing but then resumes, eventually finishing the video.
  • Note: Media Player works better if Media Server is wired to an access point instead of being the access point.

Notes on Failed Tests

Actions #32

Updated by Hammel over 1 year ago

RPi 3 Model B+, Media Player

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
Network Wired Eth gets DHCP Pass
UI Matchbox App overlays launcher Pass
Launcher Icons x rows by y columns icons Pass
Date/time Pass
Navigation Use kb arrows to nav app selection Pass
App Manager Start app via launcher Pass
PiNet Touch Interface Exit N/A
Web Config Access Point config Pass
Wireless client UI Pass
Wireless client config Pass Works after fixing wpa_supplicant.conf to match router. See RM #904
Piboxd SMB mounts Pass
VideoFE Selection Arrow keys Pass
Search Pass
Title access, SMB Pass
Title access, USB Pass
Playback Start video, USB Pass
Start video, SMB Pass
FF Pass
Rewind Pass
Exit Pass
Full screen Pass
Video Formats Test multiples files Pass
Video Stream Stream from Media System Pass
MusicFE Selection by title Arrow Keys Pass
Selection by Artist Arrow Keys Pass
Playback Start audio Pass
FF Fail See RM #921
Rewind Fail See RM #921
Exit Pass

Notes on Passed Tests

Notes on Failed Tests

Actions #33

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #34

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #35

Updated by Hammel over 1 year ago

RPi 1 Model B+, Media Player

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
Network Wired Eth gets DHCP Pass
UI Matchbox App overlays launcher Pass
Launcher Icons x rows by y columns icons Pass
Date/time Pass
Navigation Use kb arrows to nav app selection Pass
App Manager Start app via launcher Pass
PiNet Touch Interface Exit N/A
Web Config Access Point config Pass See RM #944
Wireless client UI Pass
Wireless client config Pass
Piboxd SMB mounts Pass
VideoFE Selection Arrow keys Pass
Search Pass
Title access, SMB Pass
Title access, USB Pass
Playback Start video, USB Pass
Start video, SMB Pass
FF Pass
Rewind Pass
Exit Pass
Full screen Pass
Video Formats Test multiples files Pass
Video Stream Stream from Media System Pass
MusicFE Selection by title Arrow Keys Pass
Selection by Artist Arrow Keys Pass
Playback Start audio Pass
FF Fail See RM #921
Rewind Fail See RM #921
Exit Pass

Notes on Passed Tests

  1. The RPi 1 UI can be painfully slow at times.

Notes on Failed Tests

Actions #36

Updated by Hammel over 1 year ago

RPi 1 Model B+, Kiosk, HDMI Display

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
Network Wired Eth gets DHCP Pass
UI Matchbox App overlays launcher Pass
Launcher Icons x rows by y columns icons Pass
Splash Displays large icon per app Pass
Date/time Pass See RM #945
Navigation Use kb arrows to nav app selection Pass
App Manager Start app via launcher Pass
VideoFE Playback Start video Pass
Nav, kb FF Pass.
Rewind Pass
Nav, touchscreen FF N/A
Rewind N/A
Exit Pass See RM #947; videofe restarts on exit if you only hit ESC once.
Full screen Pass
Video Formats Test multiples files N/A Not verified but expected to work
PiPics Nav, kb FF Pass
Rewind Pass
Nav, touchscreen FF N/A
Rewind N/A

Notes on Passed Tests

  1. The RPi 1 UI can be painfully slow at times.

Notes on Failed Tests

Actions #37

Updated by Hammel over 1 year ago

RPi 2 Model B, Kiosk, HDMI Display

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
Network Wired Eth gets DHCP Pass
UI Matchbox App overlays launcher Pass
Launcher Icons x rows by y columns icons Pass
Splash Displays large icon per app Pass
Date/time Pass See RM #945
Navigation Use kb arrows to nav app selection Pass
App Manager Start app via launcher Pass
VideoFE Playback Start video Pass
Nav, kb FF Pass
Rewind Pass
Nav, touchscreen FF N/A
Rewind N/A
Exit Pass See RM #947; videofe restarts on exit if you only hit ESC once.
Full screen Pass
Video Formats Test multiples files N/A Not verified but expected to work
PiPics Nav, kb FF Pass
Rewind Pass
Nav, touchscreen FF N/A
Rewind N/A

Notes on Passed Tests

Notes on Failed Tests

Retest Status

  1. All failed tests with fixed issues passed on retest.
Actions #38

Updated by Hammel over 1 year ago

RPi 3 Model B+, Kiosk, 7" RPi Touhscreen

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
Network Wired Eth gets DHCP Pass
UI Matchbox App overlays launcher Pass
Launcher Icons x rows by y columns icons Pass See RM #946; three columns for app ions when there should just be two
Splash Displays large icon per app Pass See RM #946; Splash is square
Date/time Pass
Navigation Use touchscreen for app selection Pass
App Manager Start app via launcher Pass
VideoFE Playback Start video Pass
Nav, kb FF N/A
Rewind N/A
Nav, touchscreen FF Pass
Rewind Pass
Exit Pass Works on touchscreen but not with keyboard.
Full screen Pass
Video Formats Test multiples files N/A Not verified but expected to work
PiPics Nav, kb FF N/A
Rewind N/A
Nav, touchscreen FF Pass
Rewind Pass

Notes on Passed Tests

Notes on Failed Tests

Retest Status

  1. All failed tests with fixed issues passed on retest.
Actions #39

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #40

Updated by Hammel over 1 year ago

  • Description updated (diff)
Actions #41

Updated by Hammel over 1 year ago

RPi Zero, Kiosk

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
Network Wired Eth gets DHCP N/A
UI Matchbox App overlays launcher Pass
Launcher Icons x rows by y columns icons Pass
Splash Displays large icon per app Pass It's arguable this is useful on small (eg. 5") HDMI displays. Also, it was missing it's rounded edges which suggests the icon is actually larger than the space provided.
Date/time Pass
Navigation Use touchscreen for app selection Pass See RM #948, #949, #950; 5" HDMI not recognized as touchscreen, wired and wireless keyboard arrow keys don't select apps
App Manager Start app via launcher Pass
VideoFE Playback Start video Pass
Nav, kb FF Pass
Rewind Pass
Nav, touchscreen FF N/A Not Tested
Rewind N/A Not Tested
Exit Pass
Full screen Pass
Video Formats Test multiples files N/A Not Tested
PiPics Nav, kb FF Pass
Rewind Pass
Nav, touchscreen FF N/A Not Tested
Rewind N/A Not Tested

Notes on Passed Tests

Notes on Failed Tests

General Notes

  1. Tested using a ELECROW Touchscreen 5in 800x480 HDMI
  2. Tested using a standard HDMI display.

Pi Zero did not work with either the touchscreen or wired/wireless keyboards. It's clear these need much more work.

Retest Status

  1. All failed tests with fixed issues passed on retest.
Actions #42

Updated by Hammel over 1 year ago

RPi Zero W, Kiosk

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
Network Wired Eth gets DHCP Pass
UI Matchbox App overlays launcher Pass
Launcher Icons x rows by y columns icons Pass
Splash Displays large icon per app Pass It's arguable this is useful on small (eg. 5") HDMI displays. Also, it was missing it's rounded edges which suggests the icon is actually larger than the space provided.
Date/time Pass
Navigation Use touchscreen for app selection Pass See RM #948, #949, #950; 5" HDMI not recognized as touchscreen, wired and wireless keyboard arrow keys don't select apps
App Manager Start app via launcher Pass
VideoFE Playback Start video Pass
Nav, kb FF Pass
Rewind Pass
Nav, touchscreen FF N/A Not tested
Rewind N/A Not tested
Exit Pass
Full screen Pass
Video Formats Test multiples files N/A Not tested
PiPics Nav, kb FF Pass
Rewind Pass
Nav, touchscreen FF N/A Not tested
Rewind N/A Not tested

Notes on Passed Tests

Notes on Failed Tests

General Notes

  1. Tested using a ELECROW Touchscreen 5in 800x480 HDMI
  2. Tested using a standard HDMI display.

Pi Zero W did not work with either the touchscreen or wired/wireless keyboards. It's clear these need much more work.

Retest Status

  1. All failed tests with fixed issues passed on retest.
Actions #43

Updated by Hammel about 1 year ago

  • Description updated (diff)
Actions #44

Updated by Hammel about 1 year ago

  • Blocked by Bug #949: Pi Zero doesn't work with keyboards using elecrow 5" HDMI display added
Actions #45

Updated by Hammel about 1 year ago

  • Blocked by Feature #948: Support elecrow 5" hdmi touchscreen display added
Actions #46

Updated by Hammel about 1 year ago

  • Description updated (diff)
Actions #47

Updated by Hammel about 1 year ago

RPi 1, Auto Kiosk, Desktop Display

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
VideoFE Playback Start video Pass
Next Pass
Loop Pass
Full screen Pass
Video Formats Test multiples files Pass
Actions #48

Updated by Hammel about 1 year ago

RPi 2, Auto Kiosk, Desktop Display

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
VideoFE Playback Start video Pass
Next Pass
Loop Pass
Full screen Pass
Video Formats Test multiples files Pass
Actions #49

Updated by Hammel about 1 year ago

RPi 3, Auto Kiosk, 7" Touchscreen

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
VideoFE Playback Start video Pass
Next Pass
Loop Pass
Full screen Pass
Video Formats Test multiples files Pass
Actions #50

Updated by Hammel about 1 year ago

  • Description updated (diff)
Actions #51

Updated by Hammel about 1 year ago

  • Description updated (diff)
Actions #52

Updated by Hammel about 1 year ago

  • Description updated (diff)
Actions #53

Updated by Hammel about 1 year ago

  • Description updated (diff)
Actions #54

Updated by Hammel about 1 year ago

RPi Zero W, Auto Kiosk, Desktop Display

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
VideoFE Playback Start video Pass
Next Pass
Loop Pass
Full screen Pass
Video Formats Test multiples files Pass

General Notes

  1. Works okay depending on the display. Some monitors flash off and on. Others have some artifacts. In general, display support is not as good as Pi 1/2/3 boards. This might be attributable to the specific Pi Zero W used in testing.
Actions #55

Updated by Hammel about 1 year ago

RPi Zero, Auto Kiosk, Desktop Display

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
VideoFE Playback Start video Pass
Next Pass
Loop Pass
Full screen Pass
Video Formats Test multiples files Pass

General Notes

  1. Display worked better than the Pi Zero W, but was only tested on a smaller display (Zero W was tested on a large display first, then the smaller one).
Actions #56

Updated by Hammel about 1 year ago

  • Description updated (diff)
Actions #57

Updated by Hammel about 1 year ago

RPi 3, PiStore

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Pass
Network Wired Eth gets DHCP Pass
LCD Touch Interface Application start Pass
Application exit (coord box 3) Pass See RM #955; Launcher works, but other apps don't recognize exit press on touchscreen.
UI Matchbox App overlays launcher Pass
Launcher Icons x rows by y columns icons Pass
Splash Displays large icon per app N/A
Date/time Pass
Navigation Use kb arrows to nav app selection Pass See RM #949; wired and wireless keyboards did not work.
App Manager Start app via launcher Pass
PiStore Touch Interface Exit Pass
Usage Display Pass
Mount Points Pass See RM #955; touch interface not working in app.
PiNet Touch Interface Exit Pass
LCD animation Pass
Web Config Set wifi client config Pass

General Notes

  1. Powered USB hub is recommended for use with large disks as the Pi can't supply enough power for some PD (re: host powered) mobile drives.
  2. PiStore needs documentation on where to touch the screen for a given function.
Actions #58

Updated by Hammel about 1 year ago

  • Description updated (diff)
Actions #59

Updated by Hammel about 1 year ago

RPi 3, PiSentry

Subsystem Feature Test Status Notes
Opkg Install Automated installation of opkgs Pass
Splash Sequential update at boot Fail See RM #961; splash is not being shown on PiSentry
Network Wired Eth gets DHCP Pass
UI Matchbox App overlays launcher Pass
Launcher Icons x rows by y columns icons Pass
Splash Displays large icon per app N/A
Date/time Pass
Navigation Use kb arrows to nav app selection Pass
App Manager Start app via launcher Pass
PiCam Video Display Start video Pass
Exit video Pass But sometimes takes awhile to exit. And may not restart without power cycle.
PiNet Touch Interface Pass
Web Config Pass
Web UI WebCam Normal Orientation Pass
Flip Orientation Pass
Actions #60

Updated by Hammel about 1 year ago

  • Description updated (diff)
Actions #61

Updated by Hammel about 1 year ago

  • Description updated (diff)
Actions #62

Updated by Hammel about 1 year ago

  • Description updated (diff)
Actions #63

Updated by Hammel about 1 year ago

  • Description updated (diff)

VideoLib

Subsystem Feature Test Status Notes
UI Menu Save Pass
Quit Pass
Compression Pass
About Pass
Details Pass
Poster Pass
TV Scan Pass
Movie Scan Pass
Actions #64

Updated by Hammel about 1 year ago

  • % Done changed from 20 to 100

Testing is complete for the 2.0 release.

Actions #65

Updated by Hammel about 1 year ago

  • Blocked by deleted (Feature #948: Support elecrow 5" hdmi touchscreen display)
Actions #66

Updated by Hammel about 1 year ago

  • Related to deleted (Testing #765: Test PiZero with media, kiosk and auto-kiosk builds)
Actions #67

Updated by Hammel about 1 year ago

  • Related to Testing #894: Generate release candidates builds: Harkonnen added
Actions #68

Updated by Hammel about 1 year ago

  • Status changed from In Progress to Closed
Actions #69

Updated by Hammel 9 months ago

  • Copied to Testing #1044: System Integration Tests for Corrino (v3.0) Release added
Actions

Also available in: Atom PDF