Project

General

Profile

Actions

Action Item #508

closed

Add IoT messaging to PiBox protocol

Added by Hammel almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Immediate
Assignee:
Category:
Sensors
Start date:
09 Mar 2016
Due date:
% Done:

100%

Estimated time:
Severity:
01 - Critical

Description

The protocol spec needs to be extended to support requesting data from piboxd and sending data to piboxd. This includes
  1. device type
  2. device features
  3. device states

There are probably others. It's not clear if the protocol should send lightweight messages and let the endpoints decipher or if the message should be self-defining. The latter seems better, using JSON underneath (the parson library recently added to piboxd). The problem is that the device itself may not be able to use the library easily. There may be some json libraries for the ESP8266. I'll have to check on that.

This is required to support the iotapp display and control via piboxd.

Actions

Also available in: Atom PDF