Bug #912


Fix permissions of package files for all apps

Added by Hammel about 1 year ago. Updated 1 day ago.

04 - Applications
Target version:
Start date:
12 Oct 2022
Due date:
% Done:


Estimated time:
01 - Critical


Most apps probably don't chown root.root the files in the .opk archive. This needs to be fixed for all apps.

Actions #1

Updated by Hammel 6 months ago

  • Target version changed from 2.0 - Harkonnen to 3.0 - Corrino
Actions #2

Updated by Hammel 2 months ago

  • Priority changed from Urgent to Immediate
Actions #3

Updated by Hammel about 2 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20

Checking first batch of apps from media system.

  • appmgr
  • launcher
  • mjpg-streamer
  • omxplayer
  • piboxd
  • pmsui
  • piboxwww
  • piclock
  • psplash
  • pipics
  • videofe
  • musicfe
  • picam
  • pixm
  • piconf
Actions #4

Updated by Hammel about 2 months ago

  • % Done changed from 20 to 60
Actions #5

Updated by Hammel about 2 months ago

pipics was just plain wrong, though it worked. The postinst script was obviously copied from videofe because it tried to set perms on videofe files.

I've fixed the install ownership and postinst but need to try it on a media system to make sure it works as expected.

Actions #6

Updated by Hammel about 2 months ago

Verified pipics is working on media system on rpi3 hardware.

Actions #7

Updated by Hammel about 1 month ago

  • % Done changed from 60 to 70
Actions #8

Updated by Hammel 26 days ago

All of the old PiBox systems apps are updated.

These are the Ironman apps that need checking.

  • gpio
  • ironmancfg
  • monitor
  • sensors
  • www
Actions #9

Updated by Hammel 1 day ago

  • Status changed from In Progress to Closed
  • % Done changed from 70 to 100

I think this is now complete. I'll fix any others I run across as I find them.

Closing issue.


Also available in: Atom PDF