Project

General

Profile

Actions

Feature #810

closed

Need updated config.txt options if 7" touchscreen is found

Added by Hammel over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Immediate
Assignee:
Category:
02 - GPU Firmware
Target version:
Start date:
15 Feb 2021
Due date:
% Done:

100%

Estimated time:
Severity:
03 - Medium

Description

The RPi3 connected to an official 7" HDMI display plays videos with lots of jitter. This is not a GPU/CPU problem nor is it a network transfer problem. It's likely a display configuration problem. I found a fix by modifying the config.txt.

I can check the name of the monitor in firstboot with this:

  1. /opt/vc/bin/tvservice -n
    device_name=Ras-LCD Panel

I need to update config.txt with the following options if the display is found to be the 7" touchscreen. Some of this is already done in firstboot.

diff firmware/config.txt updated/config.txt
36a37,38
> hdmi_ignore_edid=0xa5000080
>
58c60
< #config_hdmi_boost=4
---
> config_hdmi_boost=7
91c93
< # gpu_mem=128
---
> gpu_mem=320
101a104,122
> initramfs initramfs.gz followkernel
>
> # Raspberry Pi Touchscreen setup
> dtoverlay=rpi-ft5406-overlay
> lcd_rotate=2
> framebuffer_width=800
> framebuffer_height=480
> fbwidth=800
> fbheight=480
> dtoverlay=pi3-disable-wifi
> hdmi_group=2
> hdmi_mode=87
> hdmi_cvt=800 480 60 6 0 0 0
> hdmi_drive=1
>
> force_turbo=1
> arm_freq=1400
> core_freq=500
> over_voltage=4
Actions #1

Updated by Hammel over 1 year ago

  • Category set to 02 - GPU Firmware
  • Assignee set to Hammel
  • Priority changed from Normal to Immediate
  • Target version set to 2.0 - Harkonnen
Actions #2

Updated by Hammel over 1 year ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20

This actually requires two new functions in the functions include script used by first boot: optimizeBoard() and optimizeTouchScreen(). The former adds overclocking options based on the identified board type (only RPi 2 and 3 are updated, Zero is identified but no overclocking is required for it). The latter adds optimizations for the official Raspberry Pi 7" touch screen.

I've implemented these in the rpi3 tree. They are about to be tested on hardware, an RPi3 with an official 7" touch screen.

Actions #3

Updated by Hammel over 1 year ago

  • % Done changed from 20 to 50

The changes work but there was no improvement on video playback. The same updates were applied by hand to a previous build and video playback started working quite well. This suggests the problem is the network. I need to retry the latest build to verify jitter still exists, then switch to the SD card with the manual update and see if that works better.

Actions #4

Updated by Hammel over 1 year ago

  • Status changed from In Progress to Closed
  • % Done changed from 50 to 100

The changes have been applied to firstboot and functions scripts, tested on hardware and appear to work fine.

Testing was inconclusive with respect to how much this helps. It seems that playback with the wifi dongle I'm using is hit or miss. It may be the media server's problem (which is supplying the video) or the piplayer system. I tried three different SD cards. One worked all the time. Another worked sometimes and sometimes would hang trying to display the config.txt when ssh'd into the device. The third had jitter but wasn't tested as many times as the first two SD cards.

I think the jitter problem is a network problem, so I'm okay with these fixes here.

Committed and pushed.

Closing issue.

Actions

Also available in: Atom PDF