Project

General

Profile

Actions

Bug #800

closed

launcher return doesn't update icon highlight for active selection.

Added by Hammel almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Immediate
Assignee:
Category:
General
Start date:
02 Dec 2020
Due date:
% Done:

100%

Estimated time:
Severity:
02 - High

Description

When pinet exits the launcher is redisplayed but the active highlight is not set.

This can probably be fixed by calling selectApp() again after the app start request is sent to appmgr.

Actions #1

Updated by Hammel almost 3 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20

selectApp() is already called in this way. The problem is that an expose_event is probably not occurring when the launcher is redisplayed. I need to test this theory with some debug in the launcher.

There is a simple synchronization between appmgr and launcher via SIGUSR1. The appmgr signals the launcher when the app the launcher requested the appmgr to start has exited. This is where a call to selectApp() could be done, possibly via a timer to allow the launcher to be fully displayed before the highlight is drawn.

Actions #2

Updated by Hammel almost 3 years ago

  • Subject changed from pinet return doesn't update highlight selection. to launcher return doesn't update icon highlight for active selection.
  • Status changed from In Progress to Closed
  • % Done changed from 20 to 100

The timer was part of the fix. The piplayer icons are large enough that the iconPad (extra space allotted to the highlight behind the icons) wasn't enough to be able to see the highlight. It was there, just barely visible around the edges of the icons. So for piplayer, the iconPad is doubled if on a touchscreen. If not, the pad doesn't need to change.

I also fixed a bug where the highlight was being drawn on a selected icon when on a touchscreen without clearing the currently active highlight (which might be on a different icon).

Changes tested on hardware, committed and pushed.

Closing issue.

Actions

Also available in: Atom PDF