Action Item #493


Update core components

Added by Hammel over 8 years ago. Updated over 8 years ago.

00 - Basic Build Issues
Target version:
Start date:
28 Jan 2016
Due date:
% Done:


Estimated time:
01 - Critical


Things have been going slow lately due to work on other projects, so I think it's time to update the core of PiBox. This means updating the toolchain, kernel, and root file system builds using the latest upstream releases, or at least as close to that as I dare.

Actions #1

Updated by Hammel over 8 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 30

After attempting an update I ran into some problems getting the latest 4.1.y kernel tree to work. So instead of bumping ahead there I decided just to make sure buildroot was up to date and that I was using the latest toolchain I could manage.

I'm now building with 3.12.x headers for the toolchain against a 3.14.y kernel from the upstream kernel repo for Raspberry Pi. Buildroot is also updated to know that the toolchain is at 3.12.x. That should get me working again. Then the majority of changes will come in buildroot, where lots of packages have changed. I'm sticking with the 2015.02 release for now. The next round of core updates will look at migrating to 2015.11 or later and a later kernel.

Actions #2

Updated by Hammel over 8 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 30 to 100

I got a full build to complete on both CentOS 6.7 and Fedora 22. However, the binary built on Fedora 22 crashes as soon as I try to run pibox-network-config. The most likely cause of this is the changes I made to the toolchain, specifically the gcc compiler.

So I decided to go back to the old toolchain but built with the newer Crosstool-NG (1.22), but that doesn't support the exact gcc (4.7.3) I had used previously. So I tried the next closest one, 4.7.4. Unfortunately, Fedora 22 has gcc 5.x and that won't compile gcc older than 4.8 (re: 4.7.x and earlier) due to some bug. I lost the output I had and the link that told me this was the case, but I know it's a fact (that lost link had a patch for it). So I bumped up to gcc 4.8.5. That built and is now being used to rebuild the rest of the distribution, which I'll try as soon as the build completes.

If this does the same thing I'll revert to xcc 1.19.0 and try again.


Verified build is working on Fedora 22. Also verified that this build, with the 4.8.5 version of gcc, does not crash when I start pibox-network-config.

More testing is necessary but I'm fairly confident this will be a working configuration for a while to come. At least the toolchain is.

Closing issue. Will open new issues against the new build as necessary.


Also available in: Atom PDF