Bug #300


tvservice stopped working

Added by Hammel about 10 years ago. Updated about 10 years ago.

02 - GPU Firmware
Target version:
Start date:
23 Mar 2014
Due date:
% Done:


Estimated time:
01 - Critical


I get this when I run any of the /opt/vc/bin programs:

  1. ./tvservice -s
    [E] Failed to initialize VCHI (ret=-1)
  1. ./vchiq_test -s abcd -f 1
    Functional test - iters:1 ======== iteration 1 ========
    vchiq_test: 615: vchiq_initialise(&instance) != VCHIQ_SUCCESS

I ran strace on the latter and got this:

open("/dev/vchiq", O_RDWR) = -1 ENOTCONN (Transport endpoint is not connected)

I think the problem here is that I upgraded to the 3.10.y kernel but didn't rev the RPi firmware. I need to rev the latter and try again, then try rev'ing the kernel to HEAD and see if that's working yet. Previously it was thought it wasn't working because of boot problems with usb drivers, but that may not really be the case.

Actions #1

Updated by Hammel about 10 years ago

  • % Done changed from 0 to 10

Updated rpifw to master. Ran tvservice -s and got a slightly different result:

# ./tvservice -s
vchiq_lib: Incompatible VCHIQ library - driver version 6 (min 3), library version 2 (min 2)
[E] Failed to initialize VCHI (ret=-1)

Not sure what this means but a google search seems to say its not a problem. But tvservice still doesn't work. So I'm upgrading the vchiq libraries (gles target) and trying again.

Actions #2

Updated by Hammel about 10 years ago

  • Status changed from New to In Progress
  • % Done changed from 10 to 80

That did the trick. When I run tvservice -s now I get the correct output.

# /opt/vc/bin/tvservice -s
state 0x120016 [DVI DMT (83) RGB full 16:9], 1600x900 @ 60Hz, progressive

Now I can go back to RM#240 and see if this displays useful info when the HDMI is not plugged in.

Still need to check in the updates. Then I'll close this issue.

Actions #3

Updated by Hammel about 10 years ago

Updates pushed upstream.

I want to do one more clean build of the whole system (sans toolchain) to make sure this is actually fixed correctly. I know bumping to master for the gles and rpi firmware is the fix, I just want to make sure it's been done correctly in the build.

Actions #4

Updated by Hammel about 10 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 80 to 100

Verified - a new build comes up just as expected and tvservice works.

Closing issue.


Also available in: Atom PDF