Project

General

Profile

Actions

Action Item #186

closed

Xorg needs a second boot after firstboot to get keyboard working. Why?

Added by Hammel over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
04 - Root File System
Target version:
Start date:
24 Apr 2013
Due date:
% Done:

100%

Estimated time:
Severity:
03 - Medium

Description

The keyboard doesn't seem to work after 2nd boot. I experimented with X configuration to no avail. But then I rebooted and it started working. Does Xorg need an extra boot before it starts working?

Actions #1

Updated by Hammel over 8 years ago

  • Priority changed from Immediate to High
Actions #2

Updated by Hammel about 8 years ago

  • Target version changed from 0.5.0 - Beta 1 to 2.0 - Harkonnen
Actions #3

Updated by Hammel about 8 years ago

  • % Done changed from 0 to 10

This still happens and is more consistent these days. I've found that if I restart just X.org after the boot then the keyboard starts working.

Still don't know what the cause of the problem is, however.

Actions #4

Updated by Hammel almost 8 years ago

  • Status changed from New to Closed
  • % Done changed from 10 to 100

I think this is caused by the powered USB hub. If I disconnect some devices before boot it seems to be okay. This is a known problem if you search for it on RPi's elinux.org hub.

The fix is to get a better USB hub. Closing issue since it's not a software problem.

Actions

Also available in: Atom PDF