Bug #693

Rotation doesn't work with display

Added by Hammel 21 days ago. Updated 13 days ago.

Status:NewStart date:02 Mar 2019
Priority:ImmediateDue date:
Assignee:Hammel% Done:

10%

Category:-
Target version:v0.1
Severity:02 - High

Description

Setting display_rotate=1 rotates the screen and X.org but the display only uses about half the screen space.
Setting lcd_display_rotate=1 rotates the screen but not X.org.

xrandr also doesn't seem to work but it's possible it won't work without the VC4 driver loaded. This driver can break some things. There is an alternative driver, vc4-fkms-v3d available that may work better.

Also:

History

#1 Updated by Hammel 13 days ago

  • % Done changed from 0 to 10

xorg.conf can rotate and does fill the screen:

Section "Device"                                  
        Identifier          "Builtin Default fbdev Device 0" 
        Driver              "fbturbo" 
        Option              "Rotate" "CW" 
EndSection

But this needs to also have tslib rotated. Doing that requires adding "rot=1" to the linear filter in /etc/ts.conf. However, that didn't seem to work when I tried it. I still get the wrong coordinates passed in. I may need to tell the launcher that we're in rotated mode, or maybe tell the touchProcessor API that we're rotated.

Also available in: Atom PDF