Bug #626

Touchscreen not working with Ironman

Added by Hammel over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:18 May 2018
Priority:ImmediateDue date:
Assignee:Hammel% Done:

100%

Category:06 - Hardware
Target version:1.0 - Atreides
Severity:01 - Critical

Description

A limited UI doesn't do anything on an RPi3. You touch the icons and it gets highlighted but nothing gets started and the UI freezes after that. Keyboard input does not work at all.

I need to enable debug and wifi on the SD card manually so I can login to the device and watch the logs as I run tests with the UI to see what is happening.

This is a problem with the UI's touchscreen support, which means start with launcher and appmgr debug.

History

#1 Updated by Hammel over 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 10

This appears to be caused by the launcher trying to send the command request to appmgr, but the message never get's through. I don't know why yet. I can see the attempt being made from the launcher but I don't see any incoming request in appmgr. The launcher will eventually time out in the logs, but the UI never comes back. The selected icon is highlighted but the previous selected is also still highlighted.

#2 Updated by Hammel over 2 years ago

  • % Done changed from 10 to 20

The bug, as far as I can tell, is that loopback is not enabled. I need to verify this with a reboot and remote login.

After the launcher times out, pressing another icon causes the following in the log:

iconTouchGTK[launcher.c:81] INFO Touch processing disabled, skipping update

This because the app failed to get launched so appmgr never sends the SIGUSR1 signal to launcher to re-enable touch input. One possible fix (and likely just a good idea in general) is to add return codes to notify() so we know whether that worked or not. If not, then we don't disable touch input.

I'm still not sure why the previous selection highlight is not getting cleared, however.

#3 Updated by Hammel over 2 years ago

  • % Done changed from 20 to 50

Okay, this is a bug in the new code for setting up dual client and access point configurations. The bug is in the new S40network init script. It brings down all interfaces (ifdown -a) and then only brings back up, specifically, wlan0 and uap0. It doesn't bring back the lo interface. Easy fix coming....

#4 Updated by Hammel over 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 50 to 100

Fixed and pushed.

Closing issue.

Also available in: Atom PDF