Action Item #611

tslib very out of date

Added by Hammel 8 months ago. Updated 6 months ago.

Status:NewStart date:14 Mar 2018
Priority:NormalDue date:
Assignee:Hammel% Done:

0%

Category:04 - Root File System
Target version:1.0 - Atreides
Severity:01 - Critical

Description

tslib has been rev'd all the way to 1.15 since the version I currently have, which is 1.5. Buildroot has kept pace but there are a variety of tools that depend on tslib (like X.org drivers) that would need updating too.

It would seem better to rev buildroot to 2018.2 instead of trying to patch all the things I would need to patch to bring tslib up to date.

Also, the newest tslib is used much differently than the 1.5 version. So libpibox would need to be updated. That may or may not require changes to any apps that use libpibox, depending on whether or not the library API changes to support the new tslib features.

See: http://www.tslib.org/

History

#1 Updated by Hammel 8 months ago

  • Priority changed from High to Immediate

#2 Updated by Hammel 8 months ago

  • Description updated (diff)

#3 Updated by Hammel 6 months ago

  • Priority changed from Immediate to Normal

Also available in: Atom PDF