Bug #553

The UI doesn't allow setting both eth0 and wlan0

Added by Hammel about 4 years ago. Updated 8 months ago.

Status:RejectedStart date:21 Sep 2016
Priority:ImmediateDue date:
Assignee:Hammel% Done:

100%

Category:-
Target version:PiBox - 1.1.0 - Upgrades
Severity:04 - Low

Description

I can only set one or the other, not both. I need to configure both the Maker Faire demo.

History

#1 Updated by Hammel about 4 years ago

  • Priority changed from Urgent to Immediate
  • Severity changed from 01 - Critical to 02 - High

#2 Updated by Hammel about 2 years ago

  • Severity changed from 02 - High to 04 - Low

#3 Updated by Hammel over 1 year ago

  • Target version changed from 0.12.0 to 1.1.0 - Upgrades

#4 Updated by Hammel 8 months ago

  • Status changed from New to Rejected
  • % Done changed from 0 to 100

Not sure what the problem was previously but I just tried this in test mode and it seems to work fine. I can set the static addresses (or DHCP) for multiple interfaces, including the wlan0 used for the host AP.

There is a minor problem in saving DNS entries if the DNS field is empty. Right now it writes out an empty field when these are saved. And you can't have interfaces on separate networks with different nameservers. This is a complex problem for configuration of multi-homed nodes and for now I'm just going to ignore it because the primary use case is single-homed wired or wireless usage.

So I can't reproduce this problem anymore. I'm closing the issue.

Also available in: Atom PDF