Bug #461

Samba config is very minimal and likely not optimized

Added by Hammel about 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:26 Jul 2015
Priority:ImmediateDue date:
Assignee:Hammel% Done:

100%

Category:-
Target version:PiBox - 0.11.0
Severity:04 - Low

Description

Here is a description of how to optimize the settings that may improve performance.

Associated revisions

Revision ad32c114
Added by Hammel about 2 years ago

RM #461: Minor optimization for SMB configuration.

History

#1 Updated by Hammel about 2 years ago

  • Project changed from VideoFE to piboxd
  • Category deleted (Configuration)

#2 Updated by Hammel about 2 years ago

  • Priority changed from Low to Immediate
  • Severity changed from 01 - Critical to 04 - Low

#3 Updated by Hammel about 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

As far as I can tell the only improvement is to change the read/write sizes from 8192 to 65535. That should improve the situation for the cell phone, I think. It needs to be tested between the server/player.

#4 Updated by Hammel about 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 50 to 100

This is fine for smb but the network is just not as robust as it needs to be to play multiple streams. It keeps dropping out and doesn't always come back.

Closing this issue because the problem is probably not with samba but with the network stack, mostly likely the wireless driver.

Also available in: Atom PDF