Testing #425

Perform complete system build in prep for 0.10 release

Added by Hammel almost 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:23 Dec 2014
Priority:ImmediateDue date:
Assignee:Hammel% Done:

100%

Category:05 - Releases
Target version:0.10.0
Severity:01 - Critical

Description

This is being run on feynman, which is CentOS 6.5, updated to current release.

Associated revisions

Revision 2ee40af9
Added by Hammel almost 3 years ago

RM #425: libpibox will not be released with 0.10.0.

Revision c2d0ad89
Added by Hammel almost 3 years ago

RM #425: Added -c, -l and -a options to build script to allow building specific apps for testing purposes.

Revision 3d29f94e
Added by Hammel almost 3 years ago

RM #425: Added -k (clobber) to also clean out opkgs.

Revision d8d8a44c
Added by Hammel almost 3 years ago

RM #425: Add missing pthread.h include to piclock.c.

Revision d8d8a44c
Added by Hammel almost 3 years ago

RM #425: Add missing pthread.h include to piclock.c.

Revision 97c7472f
Added by Hammel almost 3 years ago

RM #425: Change default vt to 2 and tmp vt to 3.

Revision 53550fc5
Added by Hammel almost 3 years ago

RM #425: Update the default for N_PAIRWISE and N_GROUP to be TKIP instead of CCMP. This matches the piboxd (which is called from the www net config interface) and seems to be correct for my network at home.

Revision 53550fc5
Added by Hammel almost 3 years ago

RM #425: Update the default for N_PAIRWISE and N_GROUP to be TKIP instead of CCMP. This matches the piboxd (which is called from the www net config interface) and seems to be correct for my network at home.

Revision 24f4760a
Added by Hammel almost 3 years ago

RM #425: Fixed minor bugs with logging during initialization.

Revision b8f19fa6
Added by Hammel almost 3 years ago

RM #425: Fix broken log messages.

Revision a6736452
Added by Hammel almost 3 years ago

RM #425: Make videofe privileged for now to allow for vt changes in an root-run X session.

Revision 53a4812c
Added by Hammel almost 3 years ago

RM #425: Add support for generating changelogs. Add pibox repo for use with changelog generation. Fix videolib.sh cdtools script's GM_SRC setting to prevent errors when generating changelog.

Revision 3db8edb8
Added by Hammel almost 3 years ago

RM #425: CLCMD needs special handling when running in debug mode. Add -f to tag command in case it needs to be rerun. Fix CLCMD's use of --since by adding missing "=" sign. When creating master Changelog by appending repo-specific changelogs only reference files prefixed with Changelog.

Revision 26b8410e
Added by Hammel almost 3 years ago

RM #425: Fix rpm build and add launcher script.

Revision 26b8410e
Added by Hammel almost 3 years ago

RM #425: Fix rpm build and add launcher script.

History

#1 Updated by Hammel almost 3 years ago

  • % Done changed from 0 to 30

The core platform builds with no problem.

The metabuild dies in omxplayer:

make[3]: Leaving directory `/home/mjhammel/src/ximba/metabuild/bld/bld/omxplayer/ffmpeg'
arm-unknown-linux-gnueabi-strip ffmpeg_compiled/usr/local/lib/*.so
arm-unknown-linux-gnueabi-strip: 'ffmpeg_compiled/usr/local/lib/*.so': No such file
make[2]: *** [install] Error 1
make[2]: Leaving directory `/home/mjhammel/src/ximba/metabuild/bld/bld/omxplayer'
make[1]: *** [ffmpeg] Error 2
make[1]: Leaving directory `/home/mjhammel/src/ximba/metabuild/bld/bld/omxplayer'
make: *** [.omx] Error 2
Build failed for omxplayer

#2 Updated by Hammel almost 3 years ago

  • % Done changed from 30 to 50

Fixed all build problems for the metabuild. I think the omxplayer build problem was an upstream breakage that they fixed.

The core and the opkgs have been built. I'm now creating a boot SD card and will regression test this release.

#3 Updated by Hammel almost 3 years ago

Basically working except for networking. The wlan0 interface is not coming up. It keeps saying "wlan0 is not ready" or something similar.

I have to make xterm privileged to run some tests.

#4 Updated by Hammel almost 3 years ago

The CCMP configuration in wpa_supplicant.conf didn't work. It needed to be TKIP. Once I changed that the network came right up. Not sure what I should do about that. I need some expert help to choose which should be used and when.

#5 Updated by Hammel almost 3 years ago

And vt reset doesn't work. Right now I think it switches to vt4 but it needs to switch to vt3 and then back to vt2 to work correctly.

#6 Updated by Hammel almost 3 years ago

  • % Done changed from 50 to 70

The CCMP problem stems from bui-network-config setting this as the default for client mode (as opposed to hostap mode). The piboxd daemon sets these to tkip using the web interface and tkip appears to be what works for me at home. So I've changed the default in bui-network-config.

The default vt switch did not match >VT3>VT2 and I've updated that in the code but it doesn't seem to be working. The problem is that videofe is not run as a privileged app so the vt switch is ignored because the X session is not run as nobody.

The fix is either to make videofe privileged (which is what I'll do for the 0.10 release) or make X run as user nobody, which may have cascading issues associated with it.

#7 Updated by Hammel almost 3 years ago

All changes have been tested, committed and pushed upstream.

I'm now rebuilding the rootfs and then will rebuild all opkgs.

When that's done, I'll rebuild the SD card and retest.

#8 Updated by Hammel almost 3 years ago

The rebuild of the rootfs didn't pick up the changes to bui-network-config because of the cached download. I removed that and verified that it downloads and builds the current version.

Rebuilding the rootfs again and will retest once more.

#9 Updated by Hammel almost 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 70 to 100

All updates have been tested and verified. All changes are committed (there were several for the metabuild but that isn't a distributed package).

Now I"m ready to push a new release (see RM #427).

Also available in: Atom PDF