Bug #351

appmgr may not accept multiple phrase arguments

Added by Hammel about 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:30 Jun 2014
Priority:ImmediateDue date:
Assignee:Hammel% Done:

100%

Category:04 - Root File System
Target version:0.10.0
Severity:02 - High

Description

I tried passing the following to it:

/usr/bin/xterm -display :0.0 -fullscreen -fg black -bg black -e /root/omxplayer -o hdmi -r /root/Bridge_on_the_River_Kwai.mp4

But it only appears to run xterm. I need to

Associated revisions

Revision ab82e782
Added by Hammel almost 3 years ago

RM #351: Make sure inbound args are passed through completely.

History

#1 Updated by Hammel about 3 years ago

  • Target version changed from 0.9.0 to 0.10.0

Still need to investigate this. However, I got around it for now by having a videofe use a configuration file to enable debugging. That way I don't have to pass command line args to it via appmgr.

Moving to next release.

#2 Updated by Hammel almost 3 years ago

  • Priority changed from Normal to Immediate

#3 Updated by Hammel almost 3 years ago

  • Severity changed from 01 - Critical to 02 - High

#4 Updated by Hammel almost 3 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20

It may be that the only problem here is that appmgr.sh only reads $1 instead of $* when it tries to grab the payload portion of the request. Everything else in the inbound message processing in appmgr appears to be correct.

I'll test this theory.

#5 Updated by Hammel almost 3 years ago

  • % Done changed from 20 to 30

Here are some small sample mp4 clips for testing:
http://www.clipcanvas.com/a/video-clip-downloads/

Changing from $1 to $* does change the payload sent to appmgr. But it's not clear if this works. Using the sample command doesn't seem to launch the command when passed via appmgr.sh to appmgr. If I type the same command in the xterm console it works.

Here is the actual command I used:

/usr/bin/xterm -display :0.0 -fullscreen -fg black -bg black -e /usr/bin/omxplayer -o hdmi -r /root/clipcanvas_14348_offline.mp4

#6 Updated by Hammel almost 3 years ago

  • % Done changed from 30 to 40

Ah. It looks like the first arg after the command is being dropped. Here is a sample of the payload making it to appmgr.

/usr/bin/xterm :0.0 -fullscreen -fg black -bg black

The problem here is probably not appmgr.sh, it's probably appmgr but I'll need to dump the payload when it arrives to know for sure.

#7 Updated by Hammel almost 3 years ago

  • % Done changed from 40 to 80
The problem is two fold:
  1. appmgr.sh needs to pass the entire string to appmgr
  2. matchbox-panel requires the argument to appmgr.sh be enclosed in double quotes

Both of these are easily fixed. The appmgr.sh fix can be put in the repo. The matchbox panel is just a safety note for any future panel apps, though with RM #383 the matchbox panel won't be much of an issue later.

#8 Updated by Hammel almost 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 80 to 100

appmgr.sh updated and pushed upstream.

Closing issue.

Also available in: Atom PDF