Bug #298

smb seems to have stopped working

Added by Hammel over 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:16 Mar 2014
Priority:ImmediateDue date:
Assignee:Hammel% Done:

100%

Category:04 - Root File System
Target version:0.9.0
Severity:04 - Low

Description

Not sure if this is a problem with an upgraded Samba package in buildroot, but the smbd/nmbd doesn't seem to allow guests to access files. There are no errors in the log files. It just doesn't work.

This may require an updated smb.conf or might be something to do with iptables with the new kernel.

History

#1 Updated by Hammel over 6 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 10

I fiddled with a few smb.conf configurations and one time the movie started playing but then stopped. Repeated attempts to get it to play again failed.

I think this may be a network problem. I tried disabling iptables but those modules aren't even loaded on boot so that shouldn't be running. IPv6 appears to be enabled in this 3.10.y kernel so I should turn that off.

I may want to play with some different wifi dongles again. And maybe rev the kernel to the HEAD of master instead of a specific git ID.

#2 Updated by Hammel over 6 years ago

  • Priority changed from Normal to Immediate
  • Severity changed from 03 - Medium to 04 - Low

#4 Updated by Hammel over 6 years ago

  • % Done changed from 10 to 20

I tried this again on two different Pi's and I'm starting to think the problem is the network adapters. I've seen lots of errors in the system logs when trying to stream a movie.

So to test this theory I'm going to set up smb on genm and stream to feynman. These two machines are wired (no wireless). If I use the exact same config and the movie streams then the problem is definitely the wifi dongles.

#5 Updated by Hammel over 6 years ago

  • % Done changed from 20 to 40

Test succeeded. I copied the smb.conf from pibox to genm and started smb and nmb. I then mounted genm on kepler with the following command:

sudo mount -t cifs -o guest //genm/media `pwd`/mnt

That worked without a password. I then played a movie using xine. It played fine.

So I really think the problem is the network adapter in the RPi. I need to work on RM #289.

#6 Updated by Hammel over 6 years ago

  • % Done changed from 40 to 70

I switched to an Atheros adapter which may be a little better. Then I used the following command to mount pibox2 on the video playing pibox:

mount -t cifs -o username=guest,sec=ntlm //pibox2/media `pwd`/mnt

The mount worked (note the "sec=ntlm" which is required to make it work) and I was able to stream a movie and play it with omxplayer.

So this is working if the network is working. I want to test it with one pibox running as an access point and both boxes are relatively close to each other.

#7 Updated by Hammel over 6 years ago

It's hard to find usb dongles supporting a specific chip type. However, I found RT5370 dongles from ModMyPi.com in the UK. I've ordered three of those. We'll see if that helps.

#8 Updated by Hammel about 6 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 70 to 100

Tried the new dongle with a new USB flash stick with a bunch of movies on it. I connected to it with my phone and it streamed perfectly. So the problem really is with the USB network dongles.

Solution: use RTL5370 network dongles. They work. Others, not so much.

Closing issue.

Also available in: Atom PDF