Bug #283

XBMC packages overriding existing targets

Added by Hammel over 6 years ago. Updated over 4 years ago.

Status:ClosedStart date:07 Mar 2014
Priority:NormalDue date:
Assignee:Hammel% Done:

100%

Category:04 - Root File System
Target version:2.0 - Harkonnen
Severity:03 - Medium

Description

The XBMC package inserted by PiBox into Buildroot includes many packages that are now part of Buildroot. This causes Buildroot to generate message like this at initialization time:

package/xbmc/libcec/libcec.mk:30: warning: overriding commands for target `libcec-show-depends'
package/libcec/libcec.mk:33: warning: ignoring old commands for target `libcec-show-depends'
package/xbmc/libcec/libcec.mk:30: warning: overriding commands for target `libcec-clean-for-rebuild'
package/libcec/libcec.mk:33: warning: ignoring old commands for target `libcec-clean-for-rebuild'

The XBMC package should be updated to utilize Buildroot's versions of these packages. The XBMC package should offer them as an option and then select them if the user wants to use them in XBMC.

History

#1 Updated by Hammel over 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

xmbc was dropped from the core system and is not used in the media platform builds.

closing issue.

Also available in: Atom PDF